Passagem de dados ao enviar webhook

Prezados,
Criei um evento para monitorar algumas variáveis e estou tentando enviar elas por meio de um webhook através de um método post http.
Porém não estou sabendo como procedo para apontar no corpo da mensagem da plataforma ProIOT as variáveis que foram configuradas previamente no meu device.
No momento só consigo enviar um webhook com informações estáticas no corpo da mensagem.
Como devo proceder?
obs: testes no postman para o servidor remoto retornam (201) OK.

Boa noite @rubemalmeida, essa funcionalidade não estava disponível até o momento.
Foi feita uma atualização e agora você consegue colocar e arrastar a variável até o campo de texto do webhook. Clicando no bandge da variável que vai aparecer você consegue selecionar nome, valor ou timestamp.
Qualquer dúvida é só perguntar aqui mesmo

Beleza @Lucas, vi aqui essa implementação e já iniciei os testes.
Porém, agora a questão está sendo a notificação de SMS que estou recebendo, conforme segue.
image
Porém, em momento algum eu configurei o envio de SMS. Portanto, o que está ocorrendo para o log apontar tentativa de SMS?

Outra questão está numa falha temporária do webhook, conforme segue.


Ignora o status de erro pois estou fazendo testes… a questão é a gap entre as requisições.
O que houve para o envio ter cessado por volta das 23H e retornado somente as 07H ?

Portando ficam aí essas duas questões.

Olá @rubemalmeida tudo bem ?

Pegamos um probleminha de etiquetagem de eventos que já foi resolvido.
Quanto ao salto, pelo que pude verificar não há motivos para ter ocorrido. Teremos o mesmo comportamento hoje de ficar disparando eventos de hora em hora ?

Se sim vou monitorar para tentar entender o que houve.

Abs

@giulio, o dispositivo está e será mantido desligado por aproximadamente mais 1~2 dias, portando vamos manter esta thread em aberto para que assim que colocarmos on, realizemos esse teste.
E devido ao mesmo motivo terei de postergar a validação do ajuste da etiquetagem.
Te mantenho informado.

@giulio, tem ocorrido esse “apagão” no envio dos webhooks de forma periódica, todos os dias de 23H30 as 07H00, aproximadamente.
Os devices estão e serão mantidos disparando os eventos para análise de vocês, conforme solicitado.
Precisando de mais alguma informação, sigo a disposição para sanarmos essa questão…

@pedropadilha13 , o erro 500 não é o ponto em questão.

Observe que não há chamada de evento algum entre as 23H33 e 07H15

Sendo que os devices enviaram informações nesse meio tempo, conforme segue
image

Boa tarde @rubemalmeida!

Peço desculpas, realmente estava acontecendo uma falha na emissão dos eventos que já corrigi.

Vou monitorar o resultado dos uplinks que acontecerem durante a noite e confirmar que está tudo funcionando corretamente.

Atenciosamente,
Pedro

@pedropadilha13, o problema persiste.
Observando o dispositivo com deui final igual a 046d, hoje por exemplo o dispositivo seguiu enviando uplink conforme segue
image

e seguiu enviando…
image

Porém, o gap continua da mesma forma
image

Boas @rubemalmeida

Consegue verificar se resolveu ?

Obrigado

@giulio, verifiquei que desde 6a-feira ou sábado (não me recordo ao certo) passou a transmitir normalmente, sem aquele gap.
Obrigado pela atenção.

1 curtida